Search search
Help sections
FAQ

What web browsers are supported by SurveyLab?

In order to use SurveyLab you just need a computer with the web browser and access to the Internet.

SurveyLab supports the following web browsers :

  • Internet Explorer 11 or newer
  • Edge 83 or newer
  • Firefox 49 or newer
  • Chrome 49 or newer
  • Opera 42 or newer
  • Safari 9.1 or newer
     

NOTE. We are not supporting IE 10 and older versions of Internet Explorer. Please download the latest version of Firefox or Google Chrome, in order to use SurveyLab.